Ασκήσεις ΑΕΠΠ
Μεθοδολογία
Δισδιάστατων Πινάκων

ΕΥΡΕΣΗ ΚΑΙ ΕΚΤΥΠΩΣΗ ΜΕΓΙΣΤΟΥ ΣΤΟΙΧΕΙΟΥ
ΚΑΙ ΘΕΣΗΣ ΜΕΓΙΣΤΟΥ ΣΤΟΙΧΕΙΟΥ

ΜΕΓ ← Α[1,1]

ΓΡ ← 1

ΣΤ ← 1

ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ Ν

   ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ Μ

     ΑΝ Α[i,j] > ΜΕΓ ΤΟΤΕ

       ΜΕΓ← Α[i,j]

       ΓΡ← i

       ΣΤ ← j

     ΤΕΛΟΣ_ΑΝ

   ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

ΓΡΑΨΕ ‘Το μεγαλύτερο στοιχείο είναι το: ‘ , ΜΕΓ,

ΓΡΑΨΕ ‘βρίσκεται στην  γραμμή ’, ΓΡ, ‘ και στην στήλη’, ΣΤ, ‘του πίνακα.’

programmatismos-aepp-exetaseis
panellinies-aepp-mathimata
askhseis-aepp-online
mathitria-aepp-exetaseis
group-mathiton-exetaseis-aepp
group-mathiton-aepp