Ασκήσεις ΑΕΠΠ
Μεθοδολογία
Δισδιάστατων Πινάκων

ΣΕΙΡΙΑΚΗ ΑΝΑΖΗΤΗΣΗ ΣΕ ΔΙΣΔΙΑΣΤΑΤΟ ΠΙΝΑΚΑ Α[100,200]

ΔΙΑΒΑΣΕ στοιχείο

βρέθηκε ← ΨΕΥΔΗΣ

i ← 1

ΟΣΟ i <=100 ΚΑΙ βρέθηκε = ΨΕΥΔΗΣ ΕΠΑΝΑΛΑΒΕ

   j ←1

   ΟΣΟ j<= 200 ΚΑΙ βρέθηκε = ΨΕΥΔΗΣ ΕΠΑΝΑΛΑΒΕ

     AN B[ i, j ] = στοιχείο TOTE

       βρέθηκε ← ΑΛΗΘΗΣ

       γραμμή ← i

       στήλη ← j

      ΑΛΛΙΩΣ

       j ← j + 1

   ΤΕΛΟΣ_ΑΝ

   ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

i ← i +1

ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

ΑΝ βρέθηκε = ΑΛΗΘΗΣ ΤΟΤΕ

   ΓΡΑΨΕ ‘Το προς αναζήτηση στοιχείο’, στοιχείο, ‘βρέθηκε στη γραμμή: ‘, γραμμή, ‘και στη    
    στήλη: ‘, στήλη

ΑΛΛΙΩΣ

   ΓΡΑΨΕ ‘Το προς αναζήτηση στοιχείο’, στοιχείο, ‘δεν βρέθηκε στον πίνακα’

ΤΕΛΟΣ_ΑΝ

programmatismos-aepp-exetaseis
panellinies-aepp-mathimata
askhseis-aepp-online
mathitria-aepp-exetaseis
group-mathiton-exetaseis-aepp
group-mathiton-aepp