Ασκήσεις ΑΕΠΠ
Μεθοδολογία
Μονοδιάστατων Πινάκων

ΣΕΙΡΙΑΚΗ ΑΝΑΖΗΤΗΣΗ ΣΕ ΤΑΞΙΝΟΜΗΜΕΝΟ ΠΙΝΑΚΑ
Σε περίπτωση που τα στοιχεία του πίνακα Α[100] είναι ταξινομημένα σε αύξουσα διάταξη
3ος τρόπος
Για στοιχεία που εμφανίζονται στον πίνακα περισσότερες απο μία φορές

ΔΙΑΒΑΣΕ στοιχείο

βρέθηκε ← ΨΕΥΔΗΣ

i ← 1

ΟΣΟ  i <=100 ΕΠΑΝΑΛΑΒΕ

    ΑΝ Α[i] = στοιχείο ΤΟΤΕ

       βρέθηκε← ΑΛΗΘΗΣ

      ΓΡΑΨΕ ‘Βρέθηκε στη θέση’,i

    ΑΛΛΙΩΣ_ΑΝ Α[i] > στοιχείο ΤΟΤΕ

       i ← 101

    ΤΕΛΟΣ_ΑΝ

       i ← i + 1

ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

ΑΝ βρέθηκε=ΨΕΥΔΗΣ ΤΟΤΕ

   ΓΡΑΨΕ ‘Δεν βρέθηκε’

   ΤΕΛΟΣ_ΑΝ

programmatismos-aepp-exetaseis
panellinies-aepp-mathimata
askhseis-aepp-online
mathitria-aepp-exetaseis
group-mathiton-exetaseis-aepp
group-mathiton-aepp