Ασκήσεις ΑΕΠΠ
Μεθοδολογία
Μονοδιάστατων Πινάκων

ΔΥΑΔΙΚΗ ΑΝΑΖΗΤΗΣΗ
Δεδομένου ότι τα στοιχεία του πίνακα Α[100] έχουν ταξινομηθεί σε αύξουσα διάταξη

ΔΙΑΒΑΣΕ στοιχείο

αρχή←1

τέλος←100

θέση <– 0

βρέθηκε <– ΨΕΥΔΗΣ

 ΟΣΟ (αρχή <= τέλος) ΚΑΙ (βρέθηκε = ΨΕΥΔΗΣ) ΕΠΑΝΑΛΑΒΕ

    μέση ←(αρχή + τέλος) DIV 2

      ΑΝ A[μέση] = στοιχείο ΤΟΤΕ

        θέση ← μέση

        βρέθηκε ←ΑΛΗΘΗΣ

      ΑΛΛΙΩΣ _ΑΝ Α[μέση] < στοιχείο ΤΟΤΕ

        αρχή←μέση + 1

      ΑΛΛΙΩΣ

        τέλος←μέση-1

ΤΕΛΟΣ_ΑΝ

ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

ΑΝ βρέθηκε = ΑΛΗΘΗΣ ΤΟΤΕ

ΓΡΑΨΕ ‘Το προς αναζήτηση στοιχείο βρέθηκε στη θέση:’, θέση

ΑΛΛΙΩΣ

ΓΡΑΨΕ ‘ Το προς αναζήτηση στοιχείο δεν βρέθηκε’

ΤΕΛΟΣ_ΑΝ

programmatismos-aepp-exetaseis
panellinies-aepp-mathimata
askhseis-aepp-online
mathitria-aepp-exetaseis
group-mathiton-exetaseis-aepp
group-mathiton-aepp