Ασκήσεις ΑΕΠΠ
Μεθοδολογία
Μονοδιάστατων Πινάκων

«Γρήγορη» ταξινόμηση φυσαλίδας σε μονοδιάστατο πίνακα με αύξουσα διάταξη 1ος τρόπος

i ← 2

flag ← ΑΛΗΘΗΣ

ΌΣΟ i <= 100 ΚΑΙ flag = ΑΛΗΘΗΣ ΕΠΑΝΑΛΑΒΕ

   flag ← ΨΕΥΔΗΣ

     ΓΙΑ j ΑΠΟ 100 ΜΕΧΡΙ i ΜΕ ΒΗΜΑ -1

       ΑΝ Α[j-1] > Α[j] ΤΟΤΕ

          temp←Α[j-1]

          Α[j-1]←Α[j]

          Α[j]←temp

          flag ← ΑΛΗΘΗΣ

       ΤΕΛΟΣ_ΑΝ

     ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

i ← i + 1

ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

programmatismos-aepp-exetaseis
panellinies-aepp-mathimata
askhseis-aepp-online
mathitria-aepp-exetaseis
group-mathiton-exetaseis-aepp
group-mathiton-aepp