Ασκήσεις ΑΕΠΠ
Μεθοδολογία
Μονοδιάστατων Πινάκων

ΤΑΞΙΝΟΜΗΣΗ ΜΕ ΕΠΙΛΟΓΗ 2ος ΤΡΟΠΟΣ

ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 19

  posmin ← i

    ΓΙΑ j ΑΠΟ i + 1 ΜΕΧΡΙ 20

      ΑΝ Α[j] < Α[θέσηmin] TOTE

         posmin ← j

      ΤΕΛΟΣ_ΑΝ

    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

        temp ← Α[posmin]

        Α[posmin] ← Α[i]

        Α[i] ← temp

ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ  

 

programmatismos-aepp-exetaseis
panellinies-aepp-mathimata
askhseis-aepp-online
mathitria-aepp-exetaseis
group-mathiton-exetaseis-aepp
group-mathiton-aepp