Ασκήσεις ΑΕΠΠ
Μεθοδολογία
Μονοδιάστατων Πινάκων

ΣΕΙΡΙΑΚΗ ΑΝΑΖΗΤΗΣΗ ΕΝΟΣ ΣΤΟΙΧΕΙΟΥ ΣΕ ΠΙΝΑΚΑ ΚΑΙ ΕΜΦΑΝΙΣΗ ΤΕΛΕΥΤΑΙΑΣ ΘΕΣΗΣ ΠΟΥ ΤΟ ΣΤΟΙΧΕΙΟ ΑΥΤΟ ΕΝΤΟΠΙΣΤΗΚΕ

ΔΙΑΒΑΣΕ στοιχείο

 βρέθηκε← Ψευδής

ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ Ν

   ΑΝ Α[i] = στοιχείο ΤΟΤΕ

     βρέθηκε<–Αληθής

     θέση ← i

   ΤΕΛΟΣ_ΑΝ

ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

   ΑΝ βρέθηκε = Αληθής ΤΟΤΕ

     ΓΡΑΨΕ ‘Το στοιχείο  βρέθηκε στη θέση ’,θέση

   ΑΛΛΙΩΣ

     ΓΡΑΨΕ ‘Το στοιχείο δεν βρέθηκε ’

ΤΕΛΟΣ_ΑΝ

programmatismos-aepp-exetaseis
panellinies-aepp-mathimata
askhseis-aepp-online
mathitria-aepp-exetaseis
group-mathiton-exetaseis-aepp
group-mathiton-aepp