Ασκήσεις ΑΕΠΠ
Μεθοδολογία
Μονοδιάστατων Πινάκων

ΣΕΙΡΙΑΚΗ ΑΝΑΖΗΤΗΣΗ ΣΕ ΤΑΞΙΝΟΜΗΜΕΝΟ ΠΙΝΑΚΑ
Σε περίπτωση που τα στοιχεία του πίνακα Α[100] είναι ταξινομημένα σε αύξουσα διάταξη

ΔΙΑΒΑΣΕ στοιχείο

βρέθηκε ← ΨΕΥΔΗΣ

i ← 1

θέση ← 0

ΟΣΟ βρέθηκε = ΨΕΥΔΗΣ ΚΑΙ i <=100 ΕΠΑΝΑΛΑΒΕ

    ΑΝ Α[i] = στοιχείο ΤΟΤΕ

       θέση ← i

       βρέθηκε← ΑΛΗΘΗΣ

    ΑΛΛΙΩΣ_ΑΝ Α[i] > στοιχείο ΤΟΤΕ

       βρέθηκε ← ΑΛΗΘΗΣ

    ΑΛΛΙΩΣ

       i ← i + 1

    ΤΕΛΟΣ_ΑΝ

ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

ΑΝ θέση <> 0 ΤΟΤΕ

   ΓΡΑΨΕ θέση

ΑΛΛΙΩΣ

   ΓΡΑΨΕ ‘Το προς αναζήτηση στοιχείο δεν βρέθηκε’

ΤΕΛΟΣ_ΑΝ

 

programmatismos-aepp-exetaseis
panellinies-aepp-mathimata
askhseis-aepp-online
mathitria-aepp-exetaseis
group-mathiton-exetaseis-aepp
group-mathiton-aepp