Ασκήσεις ΑΕΠΠ
Μεθοδολογία
Μονοδιάστατων Πινάκων

ΣΥΓΧΩΝΕΥΣΗ ΠΙΝΑΚΩΝ ΠΟΥ ΕΧΟΥΝ ΤΑΞΙΝΟΜΗΘΕΙ Α[30] ΚΑΙ Β[50] ΣΕ ΑΥΞΟΥΣΑ ΔΙΑΤΑΞΗ ΚΑΙ ΔΗΜΙΟΥΡΓΙΑ ΝΕΟΥ ΠΙΝΑΚΑ Γ[80]

i ← 1

j ← 1

m ← 1

ΟΣΟ i <= 30 KAI j <= 50 ΕΠΑΝΑΛΑΒΕ

   ΑΝ A[i] < B[j] ΤΟΤΕ

     Γ[m] ← Α[i]

     i ← i + 1

   ΑΛΛΙΩΣ

     Γ[m] ← Β[j]

     j ← j + 1

ΤΕΛΟΣ_ΑΝ

    m ← m + 1

ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

   ΑΝ i > 30 ΤΟΤΕ

     ΓΙΑ c ΑΠΟ m ΜΕΧΡΙ 80

       Γ[c] ← Β[j]

       j ← j + 1

  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

ΑΛΛΙΩΣ

   ΓΙΑ c ΑΠΟ m ΜΕΧΡΙ 80

      Γ[m] ← Α[i]

      i ← i + 1

   ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

ΤΕΛΟΣ_ΑΝ

ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 80

   ΓΡΑΨΕ Γ[i]

ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

programmatismos-aepp-exetaseis
panellinies-aepp-mathimata
askhseis-aepp-online
mathitria-aepp-exetaseis
group-mathiton-exetaseis-aepp
group-mathiton-aepp