Ασκήσεις ΑΕΠΠ
Πίνακες

Ασκήσεις Πίνακες ΑΕΠΠ
Άσκηση 11 - Λύση

ΠΡΟΓΡΑΜΜΑ ασκ11

ΜΕΤΑΒΛΗΤΕΣ

                                               ΑΚΕΡΑΙΕΣ:i,j,ΨΗΦ[20],temp,pos   

                                                      ΧΑΡΑΚΤΗΡΕΣ:ΟΝ[20],temp2,όνομα

         ΛΟΓΙΚΕΣ: done 

ΑΡΧΗ

ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 20

    ΔΙΑΒΑΣΕ ΟΝ[i], ΨΗΦ[i]

  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  ΓΙΑ i ΑΠΟ 2 ΜΕΧΡΙ 20

    ΓΙΑ j ΑΠΟ 20 ΜΕΧΡΙ i ΜΕ ΒΗΜΑ -1

      ΑΝ ΨΗΦ[j-1] < ΨΗΦ[j] ΤΟΤΕ

temp<– ΨΗΦ[j-1]

  ΨΗΦ[j-1]<– ΨΗΦ[j]

  ΨΗΦ[j]<–temp

temp2<–ΟΝ[j-1]  

ΟΝ[j-1]<–ΟΝ[j]

ΟΝ[j]<–temp2

      ΤΕΛΟΣ_ΑΝ

    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 7

    ΓΡΑΨΕ ΟΝ[i]

  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  ΔΙΑΒΑΣΕ όνομα

  done ← ψευδής

  pos ← 0

  i ← 1

  ΌΣΟ (done = ψευδής) ΚΑΙ (i <= 20) ΕΠΑΝΑΛΑΒΕ

    ΑΝ ΟN[i] = όνομα ΤΟΤΕ

      done ← αληθής

      pos ← i

   ΑΛΛΙΩΣ

     i ← i + 1

   ΤΕΛΟΣ_ΑΝ

  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  ΑΝ done = αληθής ΤΟΤΕ

    ΑΝ pos<= 7 ΤΟΤΕ

      ΓΡΑΨΕ ‘Εκλέγεται’

    ΑΛΛΙΩΣ

      ΓΡΑΨΕ ‘Δεν εκλέγεται’

    ΤΕΛΟΣ_ΑΝ

  ΑΛΛΙΩΣ

    ΓΡΑΨΕ ‘Το όνομα που δώσατε είναι λάθος’

  ΤΕΛΟΣ_ΑΝ

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

programmatismos-aepp-exetaseis
panellinies-aepp-mathimata
askhseis-aepp-online
mathitria-aepp-exetaseis
group-mathiton-exetaseis-aepp
group-mathiton-aepp