Ασκήσεις ΑΕΠΠ
Πίνακες

Ασκήσεις Πίνακες ΑΕΠΠ
Άσκηση 3 - Λύση

ΠΡΟΓΡΑΜΜΑ ασκ3

ΜΕΤΑΒΛΗΤΕΣ

ΑΚΕΡΑΙΕΣ:Πλκ40,Ωρ[100,5],i,j,αθ,υπ

ΧΑΡΑΚΤΗΡΕΣ: ον

ΑΡΧΗ

Πλκ40<–0

ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 100

ΔΙΑΒΑΣΕ ον

αθ<–0

ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 5

ΔΙΑΒΑΣΕ Ωρ[i,j]

αθ<–αθ + Ωρ[i,j]

ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

ΑΝ αθ> 40 ΤΟΤΕ

υπ<–(αθ – 40)*5

ΓΡΑΨΕ ον, υπ

ΑΛΛΙΩΣ

Πλκ40<–Πλκ40+1

ΤΕΛΟΣ_ΑΝ

ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

ΓΡΑΨΕ Πλκ40, ‘υπάλληλοι με λιγότερες από 40 ώρες’

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

programmatismos-aepp-exetaseis
panellinies-aepp-mathimata
askhseis-aepp-online
mathitria-aepp-exetaseis
group-mathiton-exetaseis-aepp
group-mathiton-aepp