Ασκήσεις ΑΕΠΠ
Πίνακες

Ασκήσεις Πίνακες ΑΕΠΠ
Άσκηση 4 - Λύση

ΠΡΟΓΡΑΜΜΑ ασκ4
ΜΕΤΑΒΛΗΤΕΣ
                                                                ΑΚΕΡΑΙΕΣ:ΕΠΙΒ[19],i,j,ΑΠΟΒ[19],ΑΕ[19]
ΑΡΧΗ
ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 19
ΔΙΑΒΑΣΕ ΕΠΙΒ[i]
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΑΠΟΒ[1] ← 0
ΓΙΑ i ΑΠΟ 2 ΜΕΧΡΙ 19
ΔΙΑΒΑΣΕ ΑΠΟΒ[i]
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΑΕ[1] ← ΕΠΙΒ[1]
ΓΙΑ i ΑΠΟ 2 ΜΕΧΡΙ19
ΑΕ[i] ← ΑΕ[i-1] + (ΕΠΙΒ[i] – ΑΠΟΒ[i])
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
μεγ ← ΑΕ[1]
θ ← 1
ΓΙΑ i ΑΠΟ 2 ΜΕΧΡΙ19
ΑΝ ΑΕ[i] >μεγ ΤΟΤΕ
μεγ ← ΑΕ[i]
θ ← i
ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΓΡΑΨΕ θ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

programmatismos-aepp-exetaseis
panellinies-aepp-mathimata
askhseis-aepp-online
mathitria-aepp-exetaseis
group-mathiton-exetaseis-aepp
group-mathiton-aepp