Ασκήσεις ΑΕΠΠ
Πίνακες

Ασκήσεις Πίνακες ΑΕΠΠ
Άσκηση 6 - Λύση

ΠΡΟΓΡΑΜΜΑ ασκ6

ΜΕΤΑΒΛΗΤΕΣ

                     ΑΚΕΡΑΙΕΣ:i,j,ΘΕΣΗ

                                                                                            ΠΡΑΓΜΑΤΙΚΕΣ:ΕΙΣΠΡΑΞΕΙΣ[5,12],αθ,ΑΘΡ[5],ΜΕΓ

                                                      ΧΑΡΑΚΤΗΡΕΣ: ΞΕΝΟΔΟΧΕΙΑ[5] 

ΑΡΧΗ

ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 5
ΔΙΑΒΑΣΕ ΞΕΝΟΔΟΧΕΙΑ[i]
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 5
 ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 12
                 ΔΙΑΒΑΣΕ ΕΙΣΠΡΑΞΕΙΣ[i, j]
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 5
 αθ<– 0
ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 12
αθ<– αθ+ΕΙΣΠΡΑΞΕΙΣ[i, j]
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΑΘΡ[i] <– αθ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 5

                                  ΓΡΑΨΕ ΞΕΝΟΔΟΧΕΙΑ[i], ΑΘΡ[i]

ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

ΜΕΓ <– ΑΘΡ[1]
ΘΕΣΗ<– 1
ΓΙΑ i ΑΠΟ 2 ΜΕΧΡΙ 5
ΑΝ ΑΘΡ[i] > ΜΕΓ ΤΟΤΕ
ΜΑΧ <– ΑΘΡ[i]
ΘΕΣΗ <– i
TΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΓΡΑΨΕ ΞΕΝΟΔΟΧΕΙΑ[ΘΕΣΗ]

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

programmatismos-aepp-exetaseis
panellinies-aepp-mathimata
askhseis-aepp-online
mathitria-aepp-exetaseis
group-mathiton-exetaseis-aepp
group-mathiton-aepp