Ασκήσεις ΑΕΠΠ
Πίνακες

Ασκήσεις Πίνακες ΑΕΠΠ
Άσκηση 8 - Λύση

ΠΡΟΓΡΑΜΜΑ ασκ8
ΜΕΤΑΒΛΗΤΕΣ
                                                                                          ΑΚΕΡΑΙΕΣ:i,ΜΟΡΙΑ[235],άθρμτεχ,πλφτεχ,max,θέση
                         ΠΡΑΓΜΑΤΙΚΕΣ:μο,ποσ
                                                                          ΧΑΡΑΚΤΗΡΕΣ: ΟΝΟΜΑ[235],ΚΑΤΕΥΘ[235]
ΑΡΧΗ

ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 235
ΔΙΑΒΑΣΕ ΟΝΟΜΑ[i], ΜΟΡΙΑ[i]
ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
ΔΙΑΒΑΣΕ ΚΑΤΕΥΘ[i]
ΜΕΧΡΙΣ_ΟΤΟΥ ΚΑΤΕΥΘ[i] = ‘ΤΕΧΝΟΛΟΓΙΚΗ’ Η ΚΑΤΕΥΘ[i] = ‘ΘΕΤΙΚΗ’
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
άθρμτεχ<–0
πλφτεχ<–0
ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 235
ΑΝ ΚΑΤΕΥΘ[i] = ‘ΤΕΧΝΟΛΟΓΙΚΗ’ ΤΟΤΕ
άθρμτεχ<–άθρμτεχ + ΜΟΡΙΑ[i]
πλφτεχ<–πλφτεχ+ 1
ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΑΝ πλφτεχ> 0 ΤΟΤΕ
μο<–άθρμτεχ/ πλφτεχ
ΓΡΑΨΕ μο
ΑΛΛΙΩΣ
μο<–0
ΓΡΑΨΕ ‘Δεν υπάρχει φοιτητής από ΤΕΧΝΟΛΟΓΙΚΗ κατεύθυνση’
ΤΕΛΟΣ_ΑΝ
ποσ<–πλφτεχ/ 235*100
ΓΡΑΨΕ ποσ
max<–μόρια[1]
θέση<–1
ΓΙΑ i ΑΠΟ 2 ΜΕΧΡΙ 235
ΑΝ max < μόρια[i] ΤΟΤΕ
max<–μόρια[i]
θέση<–i
ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΓΡΑΨΕ ΚΑΤΕΥΘ[θέση]

ΓΡΑΨΕ ‘Φοιτητές ΤΕΧΝΟΛΟΓΙΚΗΣ με μόρια εισαγωγής περισσότερα από το Μ.Ο Τεχνολογικής’
ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 235
ΑΝ ΚΑΤΕΥΘ[i] = ‘ΤΕΧΝΟΛΟΓΙΚΗ’ ΚΑΙ ΜΟΡΙΑ[i] > μο ΤΟΤΕ
ΓΡΑΨΕ ΟΝΟΜΑ[i]
ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

programmatismos-aepp-exetaseis
panellinies-aepp-mathimata
askhseis-aepp-online
mathitria-aepp-exetaseis
group-mathiton-exetaseis-aepp
group-mathiton-aepp