Ασκήσεις ΑΕΠΠ
Πίνακες

Ασκήσεις Πίνακες ΑΕΠΠ
Άσκηση 9 - Λύση

ΠΡΟΓΡΑΜΜΑ ασκ9
ΜΕΤΑΒΛΗΤΕΣ
                   ΑΚΕΡΑΙΕΣ: i,j,θέση,πλ
                                                               ΠΡΑΓΜΑΤΙΚΕΣ: ΘΕΡ[7,24],αθ, ΜΟ[7],μεγ
                             ΧΑΡΑΚΤΗΡΕΣ: ΗΜΕΡΑ[7]
ΑΡΧΗ
ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 7
ΔΙΑΒΑΣΕ ΗΜΕΡΑ[i]
ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 24

ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
ΔΙΑΒΑΣΕ ΘΕΡ[i , j]
ΜΕΧΡΙΣ_ΟΤΟΥ Θ[i , j] >= –20 ΚΑΙ Θ[i , j] <= 50
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΓΙΑ ΑΠΟ 1 ΜΕΧΡΙ 7
αθ ← 0
ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 24
αθ ← αθ + ΘΕΡ[i, j]
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΜΟ[i] ← αθ / 24
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
μεγ ← ΜΟ[1]
θέση ← 1
ΓΙΑ i ΑΠΟ 2 ΜΕΧΡΙ 7
ΑΝ ΜΟ[i] >μεγ ΤΟΤΕ
μεγ ← ΜΟ[i]
θέση ← i
ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΓΡΑΨΕ μεγ, ΗΜΕΡΑ[θέση]
πλ ← 0
ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 7
ΑΝ ΜΟ[i] > 20 ΤΟΤΕ
πλ ← π + 1
ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΓΡΑΨΕ πλ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

programmatismos-aepp-exetaseis
panellinies-aepp-mathimata
askhseis-aepp-online
mathitria-aepp-exetaseis
group-mathiton-exetaseis-aepp
group-mathiton-aepp