Ασκήσεις ΑΕΠΠ
Υποπρογράμματα

Ασκήσεις Υποπρογράμματα ΑΕΠΠ
Άσκηση 2 - Λύση

ΠΡΟΓΡΑΜΜΑ ασκ2

ΜΕΤΑΒΛΗΤΕΣ 

                            ΠΡΑΓΜΑΤΙΚΕΣ: α,β,γ,max

ΑΡΧΗ

ΓΡΑΨΕ ‘Δώσε 3 πραγματικούς αριθμούς’

ΔΙΑΒΑΣΕ α,β,γ

max<–max_of_3(α,β,γ)

ΓΡΑΨΕ ‘Ο μεγαλύτερος αριθμός από τους 3 είναι ο: ‘ ,max

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

ΣΥΝΑΡΤΗΣΗ max_of_3(x,y,z):ΠΡΑΓΜΑΤΙΚΗ

ΜΕΤΑΒΛΗΤΕΣ

                            ΠΡΑΓΜΑΤΙΚΕΣ: x,y,z,max

AΡΧΗ

max<–x

ΑΝ y>max ΤΟΤΕ

max<–y

ΤΕΛΟΣ_ΑΝ

ΑΝ z>max ΤΟΤΕ

max<–z

ΤΕΛΟΣ_ΑΝ

max_of_3<–max

ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ

programmatismos-aepp-exetaseis
panellinies-aepp-mathimata
askhseis-aepp-online
mathitria-aepp-exetaseis
group-mathiton-exetaseis-aepp
group-mathiton-aepp