Ασκήσεις ΑΕΠΠ
Υποπρογράμματα

Ασκήσεις Υποπρογράμματα ΑΕΠΠ
Άσκηση 5- Λύση

ΠΡΟΓΡΑΜΜΑ ασκ5

ΜΕΤΑΒΛΗΤΕΣ

       ΑΚΕΡΑΙΕΣ: x,y

ΛΟΓΙΚΕΣ: y

ΑΡΧΗ

ΓΡΑΨΕ ‘Δώσε έναν αριθμό’

ΔΙΑΒΑΣΕ x

y<– ΕΛΕΓΧΟΣ(x)

ΑΝ y = ΑΛΗΘΗΣ ΤΟΤΕ

ΓΡΑΨΕ ‘Ο αριθμός είναι άρτιος’

ΑΛΛΙΩΣ

ΓΡΑΨΕ ‘Ο αριθμός είναι περιττός’

ΤΕΛΟΣ_ΑΝ

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

ΣΥΝΑΡΤΗΣΗ ΕΛΕΓΧΟΣ(z): ΛΟΓΙΚΗ

ΜΕΤΑΒΛΗΤΕΣ

ΛΟΓΙΚΕΣ: y

ΑΡΧΗ

ΑΝ y MOD 2 =0 TOTE

ΕΛΕΓΧΟΣ<–ΑΛΗΘΗΣ

ΑΛΛΙΩΣ

ΕΛΕΓΧΟΣ<–ΨΕΥΔΗΣ

ΤΕΛΟΣ_ΑΝ

ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ

programmatismos-aepp-exetaseis
panellinies-aepp-mathimata
askhseis-aepp-online
mathitria-aepp-exetaseis
group-mathiton-exetaseis-aepp
group-mathiton-aepp