Ασκήσεις ΑΕΠΠ
Υποπρογράμματα

Ασκήσεις Υποπρογράμματα ΑΕΠΠ
Άσκηση 6- Λύση

ΠΡΟΓΡΑΜΜΑ ασκ6

ΜΕΤΑΒΛΗΤΕΣ

                            ΧΑΡΑΚΤΗΡΕΣ: ΜΑΘ[300]

ΑΡΧΗ

ΚΑΛΕΣΕ ΕΙΣΑΓΩΓΗ(ΜΑΘ)

ΚΑΛΕΣΕ ΕΥΡΕΣΗ (ΜΑΘ)

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

ΔΙΑΔΙΚΑΣΙΑ ΕΙΣΑΓΩΓΗ (ΟΝ)

ΜΕΤΑΒΛΗΤΕΣ

ΑΚΕΡΑΙΕΣ: i

ΧΑΡΑΚΤΗΡΕΣ: ΟΝ[300]

ΑΡΧΗ

ΓΙΑ ΑΠΟ 1 ΜΕΧΡΙ 300

ΔΙΑΒΑΣΕ ΟΝ[i]

ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ

ΔΙΑΔΙΚΑΣΙΑ ΕΥΡΕΣΗ (ΟΝ)

ΜΕΤΑΒΛΗΤΕΣ

                 ΑΚΕΡΑΙΕΣ: i,πλήθος

                          ΧΑΡΑΚΤΗΡΕΣ: ΟΝ[300]

ΑΡΧΗ

πλήθος<–0

ΓΙΑ ΑΠΟ 1 ΜΕΧΡΙ 300

ΑΝ ΟΝ[i]>=’K’ ΚΑΙ ΟΝ[i]<’Λ’  ΤΟΤΕ

πλήθος<–πλήθος+1

ΤΕΛΟΣ_ΑΝ

ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

ΓΡΑΨΕ πλήθος

ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ

programmatismos-aepp-exetaseis
panellinies-aepp-mathimata
askhseis-aepp-online
mathitria-aepp-exetaseis
group-mathiton-exetaseis-aepp
group-mathiton-aepp