Ασκήσεις ΑΕΠΠ
Υποπρογράμματα

Ασκήσεις Υποπρογράμματα ΑΕΠΠ
Άσκηση 7- Λύση

ΠΡΟΓΡΑΜΜΑ ασκ7

ΜΕΤΑΒΛΗΤΕΣ

                                   ΑΚΕΡΑΙΕΣ: i, ΑΡΙΘ[500],x,π

ΑΡΧΗ

ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 500

ΔΙΑΒΑΣΕ ΑΡΙΘ[i]

ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

ΓΡΑΨΕ ‘Δώσε έναν αριθμό’

ΔΙΑΒΑΣΕ x

π<–Πλήθος(ΑΡΙΘ,x)

ΓΡΑΨΕ ‘Ο αριθμός που έδωσε ο χρήστης βρέθηκε:’, π, ’φορές’

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

 

ΣΥΝΑΡΤΗΣΗ Πλήθος (ΑΡΙΘ,x):ΑΚΕΡΑΙΑ

ΜΕΤΑΒΛΗΤΕΣ

                                        ΑΚΕΡΑΙΕΣ: i, ΑΡΙΘ[500],x,πλ

ΑΡΧΗ

πλ<–0

ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 500

ΑΝ ΑΡΙΘ[i]=x ΤΟΤΕ

πλ<–πλ+1

ΤΕΛΟΣ_ΑΝ

ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

Πλήθος<–πλ

ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ

 

programmatismos-aepp-exetaseis
panellinies-aepp-mathimata
askhseis-aepp-online
mathitria-aepp-exetaseis
group-mathiton-exetaseis-aepp
group-mathiton-aepp