Ασκήσεις ΑΕΠΠ
Υποπρογράμματα

Ασκήσεις Υποπρογράμματα ΑΕΠΠ
Άσκηση 9 - Λύση

ΠΡΟΓΡΑΜΜΑ Ασκ9
ΜΕΤΑΒΛΗΤΕΣ
   ΑΚΕΡΑΙΕΣ: i , j
ΠΡΑΓΜΑΤΙΚΕΣ: ΒΑΘ[100,3] , μεγ , ελαχ
ΧΑΡΑΚΤΗΡΕΣ: ΟΝ[100]
ΑΡΧΗ
ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 100
ΔΙΑΒΑΣΕ ΟΝ[i]
ΔΙΑΒΑΣΕ ΒΑΘ[i,1] , b[i,2] , b[i,3]
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 100
μεγ <– 0
ελαχ <– 21
ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 3
ΑΝ ΒΑΘ[i,j] > μεγ ΤΟΤΕ
μεγ <– ΒΑΘ[i,j]
ΤΕΛΟΣ_ΑΝ
ΑΝ ΒΑΘ[i,j] < ελαχ ΤΟΤΕ
ελαχ <– ΒΑΘ[i,j]
ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΓΡΑΨΕ ΟΝ[i], ελαχ, μεγ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

ΚΑΛΕΣΕ ΜΟ(ΟΝ , ΒΑΘ)
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

ΔΙΑΔΙΚΑΣΙΑ ΜΟ(ΟΝ , ΒΑΘ)
ΜΕΤΑΒΛΗΤΕΣ
ΑΚΕΡΑΙΕΣ : i
ΠΡΑΓΜΑΤΙΚΕΣ: ΒΑΘ[100,3] , μεσορ
ΧΑΡΑΚΤΗΡΕΣ: ΟΝ[100]
ΑΡΧΗ
ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 100
μέσορ <– (ΒΑΘ[i,1] + ΒΑΘ[i,1] + ΒΑΘ[i,1])/3
ΓΡΑΨΕ ΟΝ[i] , ‘Mέσος όρος βαθμολογίας =’, μεσορ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ

 

programmatismos-aepp-exetaseis
panellinies-aepp-mathimata
askhseis-aepp-online
mathitria-aepp-exetaseis
group-mathiton-exetaseis-aepp
group-mathiton-aepp