Ασκήσεις ΑΕΠΠ
Δομή της Επανάληψης

Ασκήσεις Δομή της Επανάληψης ΑΕΠΠ
Άσκηση 5 - Λύση

ΠΡΟΓΡΑΜΜΑ ασκ5

ΜΕΤΑΒΛΗΤΕΣ

  ΑΚΕΡΑΙΕΣ:  i,αρ, πλήθοςαρτ, πλήθοςπερ,αθαρτ,αθπερ,πλήθοςαρτ,πλήθοςπερ,πλήθοςμ100

  ΠΡΑΓΜΑΤΙΚΕΣ: μοαρτ,μοπερ

ΑΡΧΗ

αθαρτ<– 0

αθπερ<–0

πλήθοςαρτ<–0

πλήθοςπερ<–0

 πλήθοςμ100<–0

  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 1000

    ΓΡΑΨΕ ‘Δώσε έναν ακέραιο αριθμό’

    ΔΙΑΒΑΣΕ αρ

   ΑΝ αρ mod 2 =0 ΤΟΤΕ

πλήθοςαρτ<– πλήθοςαρτ+1

αθαρτ<–αθαρτ+αρ

    ΑΛΛΙΩΣ

πλήθοςπερ<– πλήθοςπερ+1

αθπερ<–αθπερ+αρ

    ΤΕΛΟΣ_ΑΝ

ΑΝ αρ<100 ΤΟΤΕ

πλήθοςμ100<–πλήθοςμ100+1

ΤΕΛΟΣ_ΑΝ

ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

μοαρτ<– αθαρτ/πλήθοςαρτ

μοπερ<–αθπερ/πλήθοςπερ

ΓΡΑΨΕ ‘Το πλήθος των άρτιων αριθμών είναι:’,πλήθοςαρτ

ΓΡΑΨΕ ‘Ο μέσος όρος των άρτιων αριθμών είναι’,μοαρτ

ΓΡΑΨΕ ‘Το πλήθος των περιττών αριθμών είναι:’,πλήθοςπερ

ΓΡΑΨΕ ‘Ο μέσος όρος των περιττών αριθμών είναι:’,μοπερ

ΓΡΑΨΕ ‘Το πλήθος των αριθμών που είναι μικρότεροι από 100 είναι:’,πλήθοςμ100

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

programmatismos-aepp-exetaseis
panellinies-aepp-mathimata
askhseis-aepp-online
mathitria-aepp-exetaseis
group-mathiton-exetaseis-aepp
group-mathiton-aepp