Ασκήσεις ΑΕΠΠ
Δομή της Επανάληψης

Ασκήσεις Δομή της Επανάληψης ΑΕΠΠ
Άσκηση 7 - Λύση

ΠΡΟΓΡΑΜΜΑ ασκ7  

ΜΕΤΑΒΛΗΤΕΣ

          ΑΚΕΡΑΙΕΣ:max,πλ,i

          ΠΡΑΓΜΑΤΙΚΕΣ: βαθ

ΑΡΧΗ

max<– 0

πλ<– 0

  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 30

    ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ

      ΓΡΑΨΕ ‘Δώσε τον βαθμό του’,i,’μαθητή’

      ΔΙΑΒΑΣΕ βαθ

    ΜΕΧΡΙΣ_ΟΤΟΥ βαθ>=1 ΚΑΙ βαθ<=20

    ΑΝ βαθ>max ΤΟΤΕ

        max<– βαθ

    ΤΕΛΟΣ_ΑΝ

    ΑΝ βαθ>18.5 ΤΟΤΕ

        πλ<– πλ+1

    ΤΕΛΟΣ_ΑΝ

  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  ΓΡΑΨΕ ‘Ο μεγαλύτερος βαθμός είναι:’,max

  ΓΡΑΨΕ ‘Το πλήθος των μαθητών που αρίστευσαν είναι’,πλ

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ 

programmatismos-aepp-exetaseis
panellinies-aepp-mathimata
askhseis-aepp-online
mathitria-aepp-exetaseis
group-mathiton-exetaseis-aepp
group-mathiton-aepp