Ασκήσεις ΑΕΠΠ
Δομή της Επανάληψης

Ασκήσεις Δομή της Επανάληψης ΑΕΠΠ
Άσκηση 8 - Λύση

ΠΡΟΓΡΑΜΜΑ ασκ 8

ΜΕΤΑΒΛΗΤΕΣ

                  ΑΚΕΡΑΙΕΣ:ξένα, ελλ

                           ΠΡΑΓΜΑΤΙΚΕΣ: αθχ,τιμή

                ΧΑΡΑΚΤΗΡΕΣ:πρ

ΑΡΧΗ

ξένα<–0

ελλ<–0

αθχ<–0

ΔΙΑΒΑΣΕ τιμή

ΌΣΟ αθχ+ τιμή <= 1500 ΕΠΑΝΑΛΑΒΕ

   ΔΙΑΒΑΣΕ πρ

αθχ ← αθχ + τιμή

   ΑΝ (πρ = ’ελληνικό’) ΤΟΤΕ

      ελλ ← ελλ + 1

   ΑΛΛΙΩΣ

      ξένα ← ξένα + 1

   ΤΕΛΟΣ_ΑΝ

   ΔΙΑΒΑΣΕ τιμή

ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

ΓΡΑΨΕ ‘ΤΕΛΟΣ ΑΓΟΡΩΝ’

ΓΡΑΨΕ αθχ

ΓΡΑΨΕ ελλ, ξένα 

ΑΝ (αθχ = 1500) ΤΟΤΕ 

   ΓΡΑΨΕ ‘ΕΞΑΝΤΛΗΘΗΚΕ ΟΛΟ ΤΟ ΠΟΣΟ’

ΑΛΛΙΩΣ

   ΓΡΑΨΕ ‘ΠΕΡΙΣΣΕΥΜΑ’, 1500-αθχ

ΤΕΛΟΣ_ΑΝ

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

programmatismos-aepp-exetaseis
panellinies-aepp-mathimata
askhseis-aepp-online
mathitria-aepp-exetaseis
group-mathiton-exetaseis-aepp
group-mathiton-aepp