Ασκήσεις ΑΕΠΠ
Δομή της Επανάληψης

Ασκήσεις Δομή της Επανάληψης ΑΕΠΠ
Άσκηση 9 - Λύση

ΠΡΟΓΡΑΜΜΑ ασκ 9
ΜΕΤΑΒΛΗΤΕΣ
ΑΚΕΡΑΙΕΣ:ν1,ν2
ΧΑΡΑΚΤΗΡΕΣ:όν1, όν2,επ1, επ2
ΑΡΧΗ

ΔΙΑΒΑΣΕ όν1, όν2,επ1, επ2
ν1 <– 0
ν2 <– 0
ΟΣΟ επ1 <>’ΤΕΛΟΣ ’ ΚΑΙ επ2 <> ‘ΤΕΛΟΣ’ ΕΠΑΝΑΛΑΒΕ
ΑΝ επ1 = ‘ΠΕΤΡΑ’ ΚΑΙ επ2 = ‘ΨΑΛΙΔΙ’ ΤΟΤΕ
ν1 <–ν1 +1
ΓΡΑΨΕ ‘ο 1ος νίκησε στο γύρο αυτό’
ΑΛΛΙΩΣ_ΑΝ επ1 = ‘ΠΕΤΡΑ’ ΚΑΙ επ2 = ‘ΧΑΡΤΙ’  ΤΟΤΕ
ν2 <– ν2 + 1
ΓΡΑΨΕ ‘ο 2ος νίκησε στο γύρο αυτό‘
ΑΛΛΙΩΣ_ΑΝ επ1 = ‘ΨΑΛΙΔΙ’ ΚΑΙ επ2 = ‘ΠΕΤΡΑ’ ΤΟΤΕ
ν2 <– ν2 + 1
ΑΛΛΙΩΣ_ΑΝ επ1 = ‘ΨΑΛΙΔΙ’ ΚΑΙ επ2 = ‘ΧΑΡΤΙ’ ΤΟΤΕ
ν1 <– ν1 + 1
ΓΡΑΨΕ ‘ο 1ος νίκησε στο γύρο αυτό’
ΑΛΛΙΩΣ_ΑΝ επ1 = ‘ΧΑΡΤΙ’ ΚΑΙ επ2 = ‘ΠΕΤΡΑ’ ΤΟΤΕ
ν1 <– ν1 + 1
ΓΡΑΨΕ ‘ο 1ος νίκησε στο γύρο αυτό‘
ΑΛΛΙΩΣ_ΑΝ επ1 = ‘ΧΑΡΤΙ’ ΚΑΙ επ2 = ‘ΨΑΛΙΔΙ’ ΤΟΤΕ
ν2 <– ν2 + 1
ΓΡΑΨΕ ‘ο 2ος νίκησε στο γύρο αυτό‘
ΑΛΛΙΩΣ
ΓΡΑΨΕ ‘Ισοπαλία’
ΤΕΛΟΣ_ΑΝ

ΔΙΑΒΑΣΕ επ1, επ2

ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

ΑΝ ν1>ν2 ΤΟΤΕ
ΓΡΑΨΕ ‘Τελικός νικητής ο 1ος: ‘, όν1
ΑΛΛΙΩΣ_ΑΝ νίκες2 > νίκες1 ΤΟΤΕ
ΓΡΑΨΕ ‘Τελικό νικητής ο 2ος:’ , όν2
ΑΛΛΙΩΣ
ΓΡΑΨΕ ‘ΤΟ ΠΑΙΧΝΙΔΙ ΕΛΗΞΕ ΙΣΟΠΑΛΟ’
ΤΕΛΟΣ_ΑΝ

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

programmatismos-aepp-exetaseis
panellinies-aepp-mathimata
askhseis-aepp-online
mathitria-aepp-exetaseis
group-mathiton-exetaseis-aepp
group-mathiton-aepp