Ασκήσεις ΑΕΠΠ
Δομή της Επιλογής

Ασκήσεις Δομή της Επιλογής ΑΕΠΠ
Άσκηση 7- Λύση

ΠΡΟΓΡΑΜΜΑ ασκ7

                  ΜΕΤΑΒΛΗΤΕΣ                         

  ΠΡΑΓΜΑΤΙΚΕΣ: y,Α

  ΧΑΡΑΚΤΗΡΕΣ: τ

ΑΡΧΗ

  ΓΡΑΨΕ ‘Δώσε υπόλοιπο κάρτας και τύπο τροχοφόρου’

  ΔΙΑΒΑΣΕ y,τ

  ΑΝ τ=’Δ’ ΤΟΤΕ

    Α <– 1.0

  ΑΛΛΙΩΣ_ΑΝ τ=’Ε’ ΤΟΤΕ

    Α <– 2.0

  ΑΛΛΙΩΣ

    Α <– 3.0

  ΤΕΛΟΣ_ΑΝ

  ΑΝ y-Α>=0 ΤΟΤΕ

    ΓΡΑΨΕ ‘Ευχαριστούμε για την πληρωμή’

    y <– y-Α

  ΑΛΛΙΩΣ_ΑΝ y=0 ΤΟΤΕ

    ΓΡΑΨΕ ‘Η κάρτα δεν έχει υπόλοιπο.Πρέπει να πληρώσετε’,Α,’ευρώ’

  ΑΛΛΙΩΣ_ΑΝ y-Α<0 ΤΟΤΕ

    ΓΡΑΨΕ ‘Το υπόλοιπο δεν επαρκεί. Οφείλετε ακόμα το ποσό των’,Α_Τ(y-Α),’ευρώ’

    y <– 0

  ΤΕΛΟΣ_ΑΝ

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

 

programmatismos-aepp-exetaseis
panellinies-aepp-mathimata
askhseis-aepp-online
mathitria-aepp-exetaseis
group-mathiton-exetaseis-aepp
group-mathiton-aepp