Ασκήσεις ΑΕΠΠ
Μεθοδολογία
Μονοδιάστατων Πινάκων

ΑΝΑΖΗΤΗΣΗ ΕΝΟΣ ΣΤΟΙΧΕΙΟΥ ΣΕ ΠΙΝΑΚΑ ΚΑΙ ΕΜΦΑΝΙΣΗ ΤΟΥ ΠΛΗΘΟΥΣ ΤΩΝ ΦΟΡΩΝ ΠΟΥ ΒΡΕΘΗΚΕ ΚΑΘΩΣ ΚΑΙ ΤΙΣ ΘΕΣΕΙΣ ΠΟΥ ΕΝΤΟΠΙΣΤΗΚΕ

ΔΙΑΒΑΣΕ στοιχείο

 Πλ← 0

ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ Ν

   ΑΝ Α[i] = στοιχείο ΤΟΤΕ

     ΓΡΑΨΕ ‘Το στοιχείο εντοπίστηκε στην θέση ’, i

     Πλ ← Πλ + 1

   ΤΕΛΟΣ_ΑΝ

ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

   ΑΝ Πλ = 0 ΤΟΤΕ

     ΓΡΑΨΕ ‘Το στοιχείο δεν βρέθηκε’

   ΑΛΛΙΩΣ

     ΓΡΑΨΕ ‘Το στοιχείο βρέθηκε ’, Πλ, ‘φορές’

ΤΕΛΟΣ_ΑΝ

programmatismos-aepp-exetaseis
panellinies-aepp-mathimata
askhseis-aepp-online
mathitria-aepp-exetaseis
group-mathiton-exetaseis-aepp
group-mathiton-aepp