Ασκήσεις ΑΕΠΠ
Πίνακες

Ασκήσεις Πίνακες ΑΕΠΠ
Άσκηση 10 - Λύση

ΠΡΟΓΡΑΜΜΑ ασκ10
ΜΕΤΑΒΛΗΤΕΣ
                                                       ΑΚΕΡΑΙΕΣ:i,ΕΤ[500],μεγ,πλ,πλγ,πλγΤ
                         ΠΡΑΓΜΑΤΙΚΕΣ:ποσοστό
                                                          ΧΑΡΑΚΤΗΡΕΣ:Ο[500],Φ[500],ΜΕ[500]
ΑΡΧΗ
ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 500
ΔΙΑΒΑΣΕ Ο[i], ΕΤ[i]
ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
ΔΙΑΒΑΣΕ Φ[i]
ΜΕΧΡΙΣ_ΟΤΟΥ Φ[i] = ‘A’ Η Φ[i] = ‘Γ’
ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
ΔΙΑΒΑΣΕ ΜΕ[i]
ΜΕΧΡΙΣ_ΟΤΟΥ ΜΕ[i] = ‘Π’ Η ΜΕ[i] = ‘Δ’ Η ΜΕ[i] = ‘Τ’
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
μεγ ← 0
πλ ← 0
πλγ ← 0
πλγΤ ← 0
ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 500
ΑΝ 2008 – ΕΤ[i] < 30 ΤΟΤΕ
πλ ← πλ + 1
ΤΕΛΟΣ_ΑΝ
ΑΝ Φ[i] = ‘Γ’ ΤΟΤΕ
πλγ ← πλγ + 1
ΑΝ ΜΕ[i] = ‘Τ’ ΤΟΤΕ
πλγΤ ← πλΤ + 1
ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΑΝ
ΑΝ 2008 – ΕΤ[i] >μεγ ΤΟΤΕ
μεγ ← 2008 – ΕΤ[i]
ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΓΡΑΨΕ πλ
ΑΝ πλγ<> 0 ΤΟΤΕ
ποσοστό ← πλγΤ / πλγ *100
ΓΡΑΨΕ ποσοστό
ΤΕΛΟΣ_ΑΝ
ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 500
ΑΝ 2008 – ΕΤ[i] = μεγ ΤΟΤΕ
ΓΡΑΨΕ Ο[i]
ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

programmatismos-aepp-exetaseis
panellinies-aepp-mathimata
askhseis-aepp-online
mathitria-aepp-exetaseis
group-mathiton-exetaseis-aepp
group-mathiton-aepp