Ασκήσεις ΑΕΠΠ
Πίνακες

Ασκήσεις Πίνακες ΑΕΠΠ
Άσκηση 7 - Λύση

ΠΡΟΓΡΑΜΜΑ ασκ7

ΜΕΤΑΒΛΗΤΕΣ

ΑΚΕΡΑΙΕΣ:i,j

ΠΡΑΓΜΑΤΙΚΕΣ:ΕΙΣΠ[10,12],αθ, ΜΟ[10],μικτιμή

ΧΑΡΑΚΤΗΡΕΣ: ΟΝΟΜΑ[10]

ΑΡΧΗ

ΓΙΑ ΑΠΟ ΜΕΧΡΙ 10
       ΔΙΑΒΑΣΕ ΟΝΟΜΑ[i]
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
   ΓΙΑ ΑΠΟ ΜΕΧΡΙ 10
      ΓΙΑ ΑΠΟ 1 ΜΕΧΡΙ 12
          ΔΙΑΒΑΣΕ ΕΙΣΠ[i, j]
     ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
   ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
   ΓΙΑ ΑΠΟ ΜΕΧΡΙ 10
      αθ<– 0
     ΓΙΑ ΑΠΟ ΜΕΧΡΙ 12
        αθ<– αθ + ΕΙΣΠ[i, j]
     ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
     ΜΟ[i] <– αθ / 12
   ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
   μικτιμή<– ΜΟ[1]
   ΓΙΑ ΑΠΟ ΜΕΧΡΙ 10
      ΑΝ ΜΟ[i] <μικτιμή ΤΟΤΕ 
          μικτιμή<– ΜΟ[i]
      ΤΕΛΟΣ_ΑΝ
   ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
   ΓΡΑΨΕ μικτιμή
   ΓΙΑ ΑΠΟ ΜΕΧΡΙ 10
      ΑΝ ΜΟ[i] = μικτιμή ΤΟΤΕ 
          ΓΡΑΨΕ ΟΝΟΜΑ[i]
      ΤΕΛΟΣ_ΑΝ
   ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

programmatismos-aepp-exetaseis
panellinies-aepp-mathimata
askhseis-aepp-online
mathitria-aepp-exetaseis
group-mathiton-exetaseis-aepp
group-mathiton-aepp