Ασκήσεις ΑΕΠΠ
Υποπρογράμματα

Ασκήσεις Υποπρογράμματα ΑΕΠΠ
Άσκηση 10 - Λύση

ΠΡΟΓΡΑΜΜΑ ασκ10
ΜΕΤΑΒΛΗΤΕΣ
ΑΚΕΡΑΙΕΣ: αθυπ, αθεπ, χωρ, επιτ

ΑΡΧΗ
αθυπ<–0
αθεπ<– 0
ΟΣΟ αθυπ< 1500 ΕΠΑΝΑΛΑΒΕ
ΓΡΑΨΕ ‘Δώσε χωρητικότητα αίθουσας: ‘
ΔΙΑΒΑΣΕ χωρ
επιτ<- αρ_επιτ (χωρ)
αθεπ<- αθεπ + επιτ
αθυπ<–αθυπ + χωρ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΓΡΑΨΕ αθεπ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

ΣΥΝΑΡΤΗΣΗ αρεπ (χωρητ): ΑΚΕΡΑΙΑ
ΜΕΤΑΒΛΗΤΕΣ
ΑΚΕΡΑΙΕΣ: χωρητ
ΑΡΧΗ
ΑΝ χωρητ<= 15 ΤΟΤΕ
αρεπ<–1
ΑΛΛΙΩΣ_ΑΝ χωρητ<= 23 ΤΟΤΕ
αρεπ<–2
ΑΛΛΙΩΣ
αρεπ<–3
ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ

programmatismos-aepp-exetaseis
panellinies-aepp-mathimata
askhseis-aepp-online
mathitria-aepp-exetaseis
group-mathiton-exetaseis-aepp
group-mathiton-aepp