Ασκήσεις ΑΕΠΠ
Υποπρογράμματα

Ασκήσεις Υποπρογράμματα ΑΕΠΠ
Άσκηση 8- Λύση

ΠΡΟΓΡΑΜΜΑ ασκ8

ΜΕΤΑΒΛΗΤΕΣ

                                                     ΠΡΑΓΜΑΤΙΚΕΣ: ΒΑΘ[100],max,min

ΑΡΧΗ

ΚΑΛΕΣΕ ΕΙΣΑΓΩΓΗ(ΒΑΘ)

max<–MAX_MIN(ΒΑΘ,1)

min<–ΜΑΧ_ΜΙΝ(ΒΑΘ,2)

ΓΡΑΨΕ ‘Η μέγιστη βαθμολογία είναι: ’,max

ΓΡΑΨΕ ‘Η μικρότερη βαθμολογία είναι: ‘,min

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

 

ΔΙΑΔΙΚΑΣΙΑ ΕΙΣΑΓΩΓΗ (ΒΑΘ)

ΜΕΤΑΒΛΗΤΕΣ

 ΑΚΕΡΑΙΕΣ: i

                                 ΠΡΑΓΜΑΤΙΚΕΣ: ΒΑΘ[100]

ΑΡΧΗ

ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 100

ΔΙΑΒΑΣΕ ΒΑΘ[i]

ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ

ΣΥΝΑΡΤΗΣΗ MAX_MIN(Β, επιλογή):ΠΡΑΓΜΑΤΙΚΗ

ΜΕΤΑΒΛΗΤΕΣ

                    ΑΚΕΡΑΙΕΣ: i, επιλογή

                            ΠΡΑΓΜΑΤΙΚΕΣ: Β[100],x

ΑΡΧΗ

x<–B[1]

ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 100

 ΑΝ επιλογή=1 ΤΟΤΕ

ΑΝ Β[i]>x ΤΟΤΕ

x<–Β[i]

ΑΛΛΙΩΣ_ΑΝ επιλογή=2 ΤΟΤΕ

ΑΝ Β[i]<x ΤΟΤΕ

x<– Β[i]

ΤΕΛΟΣ_ΑΝ

MAX_MIN<–x

ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ

 

programmatismos-aepp-exetaseis
panellinies-aepp-mathimata
askhseis-aepp-online
mathitria-aepp-exetaseis
group-mathiton-exetaseis-aepp
group-mathiton-aepp